Mikrotik — FAQ

Проброс портов

Добавим проброс порта 995 с группы интефейсов WAN интерфейса pppoe-out1 на ip 10.8.0.230 на порт 995

/ip firewall nat add action=dst-nat chain=dstnat dst-port=995 in-interface-list=WAN protocol=tcp to-addresses=10.8.0.230 to-ports=995
/ip firewall nat add chain=srcnat src-address=10.8.0.23/24 dst-address=10.8.0.230 protocol=tcp dst-port=995 action=masquerade
/ip firewall nat add action=dst-nat chain=dstnat comment="995_from_inner_to_external_ip" dst-address-type=local dst-port=995 protocol=tcp to-addresses=10.8.0.230

Mikrotic l2tp client

/interface l2tp-client add name="l2tp-out1" max-mtu=1450 max-mru=1450 mrru=disabled connect-to=$VPN_SERVER_NAME user="$VPN_USER" password="$VPN_PASSWORD" profile=default-encryption keepalive-timeout=disabled use-ipsec=yes ipsec-secret="$IP_SEC_KEY" allow-fast-path=no add-default-route=no dial-on-demand=no allow=pap,chap,mschap1,mschap2
/ip ipsec proposal set [ find default=yes ] auth-algorithms=sha1 enc-algorithms=aes-256-cbc,aes-192-cbc,aes-128-cbc lifetime=30m pfs-group=modp1024
/ip route add dst-address=$NETOWORK/24 gateway=l2tp-out1
/ip firewall nat add action=masquerade chain=srcnat out-interface=l2tp-out1

Добавить маршруты через интерфейс

/ip route add dst-address=172.21.7.0/24 gateway=l2tp-out1
/ip firewall nat add action=masquerade chain=srcnat out-interface=l2tp-out1

Удалить правило

/ip firewall nat print
/ip firewall nat  remove номер_правила

Или, например, по ключу

/ip firewall nat  remove [find dst-port="2224"]

Как закрыть порт на mikrortik

Закрыть порт — например 2000 протокол tcp на интерфейсе — например pppoe-out1

Смотрим список интерфейсов

interface print

Видим наш интерфейс
И применяем правило

/ip firewall filter add chain=input action=drop protocol=tcp in-interface=pppoe-out1 dst-port=2000

Защита ssh

/ip firewall nat
add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
comment="drop ssh brute forcers" disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
address-list-timeout=10d comment="" disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m comment="" disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no

Dns static config

print

/ip dns static print

remove entry by number

/ip dns static remove 21

add dns entry

/ip dns static add address=127.0.0.1 name=domain-a.tld

flush dns mikrotik

/ip dns cache flush
``
## Добавить vnal на микротик
Создаем vlan с id 12 на 12 интерфейсе, даем ему ip(как шлюз), далаем dhcp с пулом адресов 10.9.0.0/24
```bash
/interface vlan add comment="VLAN_12_SERVERS" interface=ether12 name="VLAN 12" vlan-id=12
/ip address add address=10.9.0.1/24 comment="VLAN_12_SERVERS Gateway" interface="VLAN 12"
/ip pool add name=VLAN_12 ranges=10.9.0.2-10.9.0.200
/ip dhcp-server network add address=10.9.0.0/24 comment="VLAN_12_SERVERS Network" dns-server=10.8.0.1 gateway=10.9.0.1
/ip dhcp-server add address-pool=VLAN_12 disabled=no interface="VLAN 12" name=VLAN_12

Добавляем маршруты

/ip route add gateway=10.9.0.1 dst-address=10.9.0.0/24

Добавляем snat(выход в инет)

/ip firewall nat add action=masquerade chain=srcnat out-interface=pppoe-out1 src-address=10.9.0.0/24

Добавить комментарий

Войти с помощью: 

Ваш адрес email не будет опубликован. Обязательные поля помечены *

 

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.